分享

CentOS 6 安裝php5.6


原本CentOS 6 的預設為php 5.3版本...實在太低很多套件都不能用
在 /etc/yum.repos.d/ 裡面的來源包加入
# vim /etc/yum.repos.d/CentOS-Base.repo
[remi-php56]
name=Les RPM de remi de PHP 5.6 pour Enterprise Linux 6 - $basearch  
mirrorlist=http://rpms.famillecollet.com/enterprise/6/php56/mirror
enabled=1
gpgcheck=0
缺的相依套件
Error: Package: php-gd-5.6.40-23.el6.remi.x86_64 (remi-php56)
          Requires: libgd.so.3()(64bit)
Error: Package: php-pecl-zip-1.19.1-1.el6.remi.5.6.x86_64 (remi-php56)
          Requires: libzip5(x86-64) >= 1.7.3
Error: Package: php-pecl-zip-1.19.1-1.el6.remi.5.6.x86_64 (remi-php56)
          Requires: libzip.so.5()(64bit)
Error: Package: php-gd-5.6.40-23.el6.remi.x86_64 (remi-php56)
          Requires: gd-last(x86-64) >= 2.1.1
補remi-safe
[remisafe]
name=remisaferepo baseurl=https://mirrors.tuna.tsinghua.edu.cn/remi/enterprise/6/safe/x86_64/
enable=1
gpgcheck=0
加入這兩段 執行 yum update 應該就能更新到5.6版了
更新後報錯 mysql 無法啟動
把/etc/my.cnf配置檔案下的[mysqld]default-character-set=utf8 改為 character_set_server=utf8
參考資料:
https://www.cadch.com/modules/news/article.php?storyid=227
https://www.cnblogs.com/f-ck-need-u/p/8538664.html
https://www.itread01.com/content/1542576022.html
https://rpms.remirepo.net/
#Centos6  #remi  #php  #mysql 
分類:學習

有時候就看到一篇有趣的文章 因為僅僅有趣 只適合分享給當下 忙碌的時候不宜看 悠閒的時候也不宜看 只有忙裡偷閒的時候適合 把亂糟糟的思緒 撥亂~反正一樣亂

評論
上一篇
  • 電腦重灌必備軟體 - 3DP Net
  • 下一篇
  • 更多文章
    載入中... 沒有更多了